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Chapter 1:
Installation

Introduction
Signature Viewer™ is a data collection, storage, and retrieval program for use with Sonoclot® Analyzers, models 
SCP1, SCP2, and SCP4.  Signature Viewer collects data when tests are run on one or more Sonoclot Analyzers.  
This data is compressed, processed for certain performance results, displayed, and stored in a database.

Computer Setup
Signature Viewer 4.1 is designed for use on standard personal computers running Windows XP and later.  Proper 
computer configuration is important for optimal Signature Viewer performance.

Minimum Hardware and Operating System Requirements
Select the computer to install Signature Viewer using the following hardware and system requirements:

•	Minimum Pentium III Processor
•	512 megabytes (MB) of RAM
•	Windows-compatible printer to print reports
•	Windows XP or later, 32-bit edition*
•	Java Runtime Environment 1.6.0_14
•	Adobe® Acrobat™ Reader 3.0 or later (needed to view the Licence Agreement and Operator’s Manual)

*NOTE: Signature Viewer does not run properly on systems greater than 32-bits.  Please contact Sienco or 
your distributor if you have any questions about your operating system.

Computer Settings
Configure the following user settings on your computer before installing Signature Viewer or starting Signature 
Viewer for the first time.

Set the System Time
Make sure that the operating system time is correct.  Signature Viewer uses the operating system time to 
date each test collected.  An incorrect system time can result in failures within Signature Viewer.  The system 
time can be set or verified within your computer’s Time and Date control panel.

Set the Power Settings
Set the sleep settings on your computer to wait at least one hour before putting the computer to sleep.  This 
prevents the computer from sleeping during test collection which can result in loss of data.

Installing Signature Viewer
1)	 Insert the installation CD into your computer’s CD Drive.

2)	 In the “My Computer” file, double-click the CD icon for Signature Viewer.

3)	 If Java is not installed, use the Windows Control Panel to remove any existing installations of Java, 
then double-click “1-Install JRE.exe” and follow the onscreen prompts.  If Java 1.6.0_14 is already 
installed, skip this step.

4)	 Double-click “2-Install SigViewr.msi” and follow the onscreen prompts.

	 Note: If you are upgrading from an older version of Signature Viewer you may install the new version 
into the same location as your exiting Signature Viewer Folder.

5)	 Optional: Install a PDF reader by double clicking “Optional-Install PDF reader.exe”.

6)	 Start Signature Viewer by double-clicking “Shortcut to Signature Viewer” located on the desktop.
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Folders and Files
The Signature Viewer installer creates all files and folders needed to run Signature Viewer.  If installation was 
successfully completed, the following folders and files should now be on your system.

The SigViewer.jar application file located in the Program Files directory.

The folder “My Signature Viewer Data” located in the “My Documents” folder.  My Signature Viewer 
folder contains the following files needed by Signature Viewer:

• jydodb.key, and jydodb.properties
Libraries needed by Signature Viewer.

•	cache
Contains files to rebuild the database.

•	svdatabase.s0 and svdatabase.s1 and/or svdatabase.s2
The database containing all collected signatures and signature groups.

•	SV_Lock
File that helps prevent database corruption.

•	USBmanager.dll

Shortcut to Signature Viewer located on the Desktop and in the “My Signature Viewer Data” folder.

Signature Viewer creates additional files as it is run that will not be present upon initial installation.

•	Log Reports

Contains exceptions logs created by Signature Viewer.

•	Corrupted Databases

Contains databases that became corrupted.

Connecting a Sonoclot Analyzer to Your Computer
You will need a 2.0 Type A Male/Type B Male USB cable to connect a Sonoclot Analyzer to your computer.  
A USB cable is provided with each analyzer.

Plug the USB cord into the back of the analyzer and a USB port on your computer and open Signature Viewer.  
Signature Viewer will automatically locate connected analyzers and a message that the analyzer has been 
found will appear in the Messages dialog box.

If the analyzer LCD displays the message “Host Inactive!” check that the USB cable is correctly connected 
to the analyzer and the computer and that Signature Viewer is running.

To prevent losing the connection between the analyzer and the computer, set the sleep settings on your 
computer to wait at least one hour before putting the computer to sleep.
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Chapter 2:
Configuration and Overview

Configuration
Sienco recommends that you complete an initial setup process before you start collecting data with Signature 
Viewer.  Follow these steps for proper setup of your computer and Sonoclot Analyzers:

Analyzer Configuration
Signature Viewer automatically configures analyzers plugged in over the USB.  When a device is found, 
a message is displayed which shows the analyzer serial number, hardware version, firmware version, and 
available channels.

An analyzer which is not connected to Signature Viewer will display the message “Host Inactive!”

Default Window Size
Using the Edit/Preferences menu, you can change the default size of the graph and summary table for new 
Signature Group Windows.

1)	 Choose “Preferences” from the View menu. 

2)	 Use the sliders to choose the size of the graph and summary table.

3)	 Click “OK” to save your changes as the default for all new Signature Group Windows.

4)	 Click “Cancel” to close the dialog box without changing the current size.
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Group Summary Setup
Signature Viewer allows you to choose what information is shown in the Group Summary portion of the 
Signature Viewer Window.

	
1)	 Choose the “Group Summary Setup...” menu item from the  “View” menu.

2)	 Click the check mark boxes in the “Field Enabled” column to enable or disable summary table fields.

3)	 Click “Save As Default Keys” to set the current settings as the default for any new signature groups.

4)	 Click “Save” to save the current settings for the open signature group.

5)	 Click “Close” to close the dialog box.  If the “Save” button was not clicked, any changes to the 
settings will not be saved.

Patient and Operator Lists
Signature Viewer allows you to manage a list of patients and a list of operators.

1)	 Choose the “Edit Patients...” or “Edit Operators...” menu item from the “View” menu.

2)	 Click “Remove” to remove the selected patient or operator from the list.

3)	 Click “Add” to bring up a dialog box in which you can enter the name or ID of a new patient or 
operator.  Click “OK” in this dialog box to add the information entered to the patient or operator list.

4)	 Click the check mark boxes in the “Active” column to enable or disable the patient or operator from 
the drop down menu in the Signature Viewer window.

5)	 Click the check mark boxes in the “Default” column to enable or disable the patient or operator 
as the default for any new test.

6)	 Click “Close” to close the dialog box, saving anything that was changed about the list.
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Tests, Applications, and Ranges
Signature Viewer allows you to choose available tests and to edit the automatic shut off time for each test.  

1)	 Choose the “Edit Tests...” menu item from the “View” menu.

2)	 �Click the check mark boxes to enable or disable the 
selected test.

3)	 �Click the Auto Shut Off Time field for a particular test to edit 
the automatic stop time for that test.  Note: The kACT, aiACT, 
and gbACT tests will automatically stop after available 
results for that test have been calculated.  If no results are 
calculated, these tests will automatically stop after the Auto 
Shut Off time set in the Enable Tests window.

4)	 �Click “Close” to close the dialog box, saving anything that 
was changed.

Signature Viewer allows you to establish applications for enabled tests and to specify ranges for each 
application.  All of these fields can be enabled or disabled.  Signature Viewer installs initial default normal 
ranges for each test.  During initial set up, these ranges should be reviewed to ensure that they match the 
current published ranges from the product insert for each test or the current normal ranges established 
by your institution.

	
1)	 Choose the “Edit Applications and Ranges...” menu item from the “View” menu.

2)	 Select a test from the Enabled Tests drop down menu.

3)	 Click “Add Application” to add a new application for the currently selected test. 

4)	 Click “Remove Application” to delete the currently selected application for a test.

5)	 Select an application from the Application drop down menu.  Click the check mark box in the 
“Enabled” field to enable or disable the selected application.

6)	 Results reported and result ranges may be customized for each test application.  Click the check 
mark boxes in the “Enabled” column next to each result to enable or disable results for the selected 
test and application.

7)	 For each result enabled, click the fields below “Range Type” to chose a result range that is above, 
below, or between desired parameters.  Click under “Lower Limit” or “Upper Limit” to enter the 
desired parameters.

8)	 Click “Set Default Application for Test” to set the current configuration as the default configuration 
for the selected test.

9)	 Click “Close” to close the dialog box, saving anything that was changed about test applications 
and ranges.



Chapter 2: Configuration and Overview 2-4

Signature Viewer Overview
Signature Viewer is designed to enhance the convenience of monitoring hemostasis performance with the 
Sonoclot® Coagulation & Platelet Function Analyzer.

The human interface is the Signature Group window.

One or more Signature Group windows will open when Signature Viewer is running.  The Signature Group 
window displays a graph of one or more Sonoclot signatures.  Each Signature Group window can collect 
new Sonoclot signatures from one or more Sonoclot Analyzers.
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Displaying multiple Sonoclot signatures is useful for monitoring an individual patient or observing a specific 
hemostasis process.  The following example illustrates the dose response of ReoPro™, a powerful platelet 
GP IIb/IIIa receptor inhibitor.
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When no signatures are selected, the Signature Group window contains general information about the entire 
Signature group.  Information may be entered by you in the Group Description field. 
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When a signature is selected, the Signature Group window contains information about the selected signature.    
The selected signature is displayed as red in the graph and highlighted in the visible portion of the Group 
Summary Table.

There are three ways to select a signature:
•	click on the signature’s graph in the Signature Group window,
•	click on the test in the Group Summary Table, 
•	or select a signature by cycling through the “Signature Selector” buttons.

You can inspect or modify details about the selected signature using the drop down menus and comment 
field in the upper right corner of the signature group.

Data Collection
Data collection will occur in a window that has the current date.  If there is not a window with the current 
date, Signature Viewer will automatically create a window with the current date to display any new signatures 
collected from a Sonoclot Analyzer.
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Chapter 3:
A Detailed Look at Signature Viewer

The Menubar
The File Menu

•	�New
	� Opens a dialog box for creating a new signature group with a 

user defined name.

•	New Data Collection Group
	� Creates a new signature group with a default time stamp name.

•	Open Signature Group
	� Opens a saved signature group.

•	Save As...
	� Saves the signature group to a new name, does not delete the 

old group.

•	Rename As...
	 Allows user to give the current signature group a new name.

•	Add Signatures…
	 Allows user to insert saved signatures.

•	Export Signature Group
	 Allows user to export the selected Signature Group.

•	Import Signature Group
Allows user to import Signature groups exported from other Signature Viewers.

•	Export as Graphics...
Allows user to save the signature group to a “JPEG”  or “PNG” graphics file.

•	Database
Expands to the submenus:

•	Clean up
This feature is currently disabled and will be available in the next version of Signature Viewer.

•	Rebuild from cache
Adds all files from the “cache” folder to the database, use to rebuild a database that became 
corrupted.

•	Print…
Prints the current signature window.

•	Print Selected Signature
Prints only the selected signature.

•	Close
Closes the current signature group.

•	Quit

Quits the program.
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The Edit Menu
The “Cut,” “Copy,” and “Paste” menus work both with signatures and text.  If 
there is an active text cursor in the Signature Group window, the items in this 
menu function relative to the text box where the text cursor is active.  If there is 
a selected signature and the graph area is outlined in blue these menus function 
relative to the selected signature.  If the graph area is not outlined in blue, click 
anywhere within the graph area to activate it for use with the Edit Menu.

•	Cut
Deletes the selected text or signature from the current signature window and places a copy of it 
on the clipboard.

•	Copy
Places a copy of the selected text or selected signature on the clipboard.

•	Paste
Places a copy of the text or signature from the clipboard onto the current signature window.

•	Clear
Clears the selected text or signature and does not place a copy on the clipboard.

•	Clear All Signatures
Upon confirmation, clears all signatures from the current signature window.

The View Menu
The View Menu contains features for configuring Signature Viewer.  
For detailed instructions on using these features, see Chapter 2.

•	 Group Summary Setup…
	� Where fields for the Group Summary Table can be configured 

for a signature group.

•	 Edit Patients…
	� Where the list of patients can be configured; changes the 

patient list for all signature groups.

•	 Edit Operators…
	� Where the list of operators can be configured for all 

signature groups.

•	Edit Tests…
Where the list of tests can be configured.

•	Edit Applications and Ranges…
Where test applications and ranges can be configured.

•	Preferences
Controls several user adjustable settings.

•	Tile Windows
Tiles open signature windows on the screen.

•	Plot Scale

Expands to allow user to increase or decrease minutes or Clot Signal units.
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The Signature Menu

•	 Automatically Color Signatures...
	 Gives each signature in the signature group a different color.

•	 Clear All Signature Colors...
	� Sets the color of all signatures in the signature group to 

default color.

•	 Sort Signatures...
	� Allows you to sort all of the signatures in the current 

Signature Group window by various criteria.

•	Recalculate Results
This feature is currently disabled.

•	Select Previous
Synonymous with the “left arrow” button to select the previous signature in the group summary 
table.

•	Select Next
Synonymous with the “right arrow” button to select the next signature in the group summary 
table.

Opening a Signature Group
Choose “Open Signature Group” from the “File” menu to bring up a dialog box which will allow you to 
open a saved Signature Group.

Preview area for 
the last clicked 
signature group.

Description area for the last 
clicked signature group.

Button to open 
the selected 
signature group.

Button to close 
the Signature 
Group browser 
window.Deletes the selected 

signature group.
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The Contents of a Signature Window
When no signatures are selected, the Signature Window looks like this:

Editable description 
area for the Signature 
Group.

Signature Group title Graph of all signatures in the 
Signature Group.

Information about each individual 
signature in the group.  The fields 
displayed can be changed, see Group 
Summary Setup.

Buttons to select the next 
or previous signature.

Buttons to increase 
or decrease the Clot 
Signal or Minutes.
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When a signature is selected, the signature window looks like this:

Note: Changing a signature’s patient, operator, application, type of test, or comment will change this 
information in all Signature groups that contain the signature.

The selected signature.

Pull down menus to change the patient, 
operator, application, or type of test.

Editable 
field for a 
comment 
about the 
signature.

Button to 
choose the 
style and 
color for the 
signature.
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Changing a Signature’s Color and Style
Signature Viewer allows you to change the color and style of a selected signature.  Style and color cannot 
be changed while analyzers are on and connected to Signature Viewer.  To change style and color, close 
Signature Viewer and either unplug the analyzers or disconnect the USB cord.  Once the analyzers have 
been disconnected, reopen Signature Viewer.

1)	 �Click the “Style and Color” button to the right of the signature to open the style and color dialog box.

2)	 �In the left column pick the color for the signature.  In the right column choose a dash pattern for 
the signature.

3)	 �Click the “Cancel” button to close the dialog without changing the color or style.

4)	 �Click the “OK” button to accept the currently selected color and style and close the dialog.
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Moving Signatures Between Signature Groups
Follow this procedure to move signatures among signature groups.  Please note that only references to 
signature files are in a signature group, not the signatures themselves.

1)	 Open both the source and destination signature groups.

2)	 Select the signature group that contains the signature that you wish to copy or move by moving 
the mouse over the signature group window and clicking the mouse button once.

3)	 Select the source graph by moving the mouse over the graph and clicking the mouse button.  This 
will let the program know to copy a signature rather than trying to copy text.  When the graph 
has been properly selected, a thick blue border is drawn around the axes.

4)	 Next, select the signature you wish to copy or move with the signature selector or with the mouse 
by clicking on the signature’s graph.  The selected signature is highlighted in red.

5)	 Next, go to the “Edit” menu and choose one of the following:

Cut	 - This will remove the reference to the selected signature from the currently visible 
group and place it on the clipboard.

Copy	 - This will leave the reference to the selected signature in the currently visible group 
but also place it on the clipboard.

Clear	 - This will remove the reference to the selected signature from the currently visible 
group but not place it on the clipboard.

6)	 To add a signature that has been cut or copied to another signature group, select the destination 
group by moving the mouse over the signature group window and clicking the mouse button 
once.  You must also select the graph of the destination group by moving the mouse over the graph 
and clicking the mouse button.  A warning sound will beep if the graph was not clicked properly.

•	 Some users find it easiest to double-click the mouse over the destination graph since doing so 
will ensure that the destination group and the graph are selected.  If the graph has been properly 
selected, a thick blue border appears around the axes.

7)	 Finally, from the “Edit” menu, choose “Paste”- the signature is then visible in the destination group 
(colored in the default signature color).

Using the “Edit” commands will not delete the signature files where the signatures are stored.  Only the 
references to the files that are associated with the involved signature groups will change.  If you accidentally 
clear a signature from a group, you can re-add the signature to the group by using the “Add Signatures…” 
menu item from the “File” menu.
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Adding Signatures to Signature Groups
1)	 Choose “Add Signatures ...” from the “File” menu.

2)	 Select the signature to be added and click on the “Add” button.

Button to close the 
signature browser window.

Button to add 
the selected 
signature to the 
signature group.

Selectable 
list of 
available 
signatures.

Buttons to change 
location to either 
the “History” or 
“Library”.

Preview area for the 
last clicked signature.

Sorting All of the Signatures in a Signature Group
Signatures within a group may be sorted by selecting “Sort Signatures” 
from the Signature menu.

The primary sort selection is what the signatures get sorted by and the 
secondary sort is a tie-breaker.  If there is a further tie, the signatures keep 
their existing relative order.
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Closing the Last Visible Signature Group Window
Since menu bars are tied to Signature Group windows, 
you cannot close the last Signature Group window.  If 
you try to close it, this dialog appears to notify you why 
the window will not close and asks if you would like to 
quit instead.

Exporting Signature Groups
Users may export Signature groups to an XML file.

To export a signature group, choose “Export Signature Group” from the File menu to bring up a dialog to 
choose a file name and destination folder for the exported XML file.  It is recommended that you give the file 
name the extension “.xml” such as “sig_group.xml”.
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Importing Signature Groups
Users may import signature groups that have been exported from Signature Viewer.  For instructions on 
importing files from previous versions of Signature Viewer, please see Chapter 4.

To import a signature group, choose “Import Signature Group” from the File menu to bring up a dialog to 
choose a XML file to import into Signature Viewer.

Warning:  Always backup data before importing data into the database.

Exporting Signature Groups to a Graphics File
With Signature Viewer you can export a signature group’s 
graphs to a graphics file for use in a word processing or slide 
show program.

To export a signature group as a graphics file, choose “Export 
as Graphics” from the File menu.

Signature Viewer allows you to scale the graph to higher factors 
so the resolution of the image will improve.  You can also 
choose the image format for the exported file.  The available 
image formats are JPEG and PNG.

Once you have chosen the scale factor and image format, click “Continue...” to export. 

Depending on the speed of your computer, this export may take several minutes.  It also requires a large 
amount of RAM memory since the program is being asked to produce a picture of a significant size and 
amount of detail.  If memory runs out, a window will appear notifying you that you did not have enough 
memory to perform the export.

It is recommended that you do not perform any exporting during data collection unless your computer has 
much more than the minimum recommended RAM requirement.
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Recommended Operating Procedures

Set the System Time
Make sure that the operating system time is correct.  Signature Viewer uses the operating system time to 
date each test collected.  An incorrect system time can result in failures within Signature Viewer.  The 
system time can be set or verified within your computer’s Time and Date control panel.

Set the Power Settings
Set the sleep settings on your computer to wait at least one hour before putting the computer to sleep 
to prevent the computer from sleeping during test collection which can result in loss of data.

Shut down Signature Viewer when not in use
To improve Signature Viewer performance, Sienco recommends closing Signature Viewer when not in use.

Enter test data and information after test collection is completed
To improve Signature Viewer performance and prevent possible communication errors, Sienco 
recommends waiting until the test is completed before entering or changing test information such as 
Patient, Operator, or adding comments.

Periodically Archive the Database
The Signature Viewer database grows over time.  As this database grows, program execution slows, 
which may cause communication problems between Signature Viewer and the Sonoclot Analyzer.  To 
ensure optimal program performance and prevent possible communication issues, Sienco recommends 
that users periodically archive and reset the database.  Follow the instructions for database maintenance 
on page A-4 and A-5.
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Chapter 4:
Advanced Options

Signature Viewer contains several options for advanced users that are not enabled by default.

To enable the advanced options of Signature Viewer, select “Preferences” from the View menu.  In the Preferences 
dialog, select the check box to “Show Advanced Menu” and click “OK.”

The Advanced Menu

•	Import From Previous Version...
	 This feature is currently disabled.

•	Export Tabbed File With Data
	� Allows user to export a Signature Group as a tabbed file with signature data for use in a 

spreadsheet program into the “Exported Files” or user defined folder.

•	Export Tabbed File Without Data
Allows user to export a Signature Group as a tabbed file without signature data for use in a 
spreadsheet program into the “Exported Files” or user defined folder; exported data includes id, path, 
results, patient, operator, application, and comment.

•	Variable Temperature (only enabled in Signature Viewer-VT PN 80-204)
Allows you to set the temperature of each channel of a connected analyzer to between 30°C and 
40°C.

Exporting Tab Delimited Files
Signature Viewer can export tab delimited files which can be read by other programs such as spreadsheets.

1)	 To export a file that contains all the data associated with the tests of the current Signature Group, 
including the X, Y data points, select the “Export Tab File With Data” from the Advanced menu.

2)	 To export a file that contains all the data associated with the tests of the current Signature Group except 
the X, Y data points select the “Export Tab File Without Data” from the Advanced menu.



Chapter 4: Advanced Options 4-2    

Using Variable Temperature Settings
Signature Viewer-VT (PN 80-204) allows the temperature of each channel of a connected analyzer to be 
changed to values between 30° and 40° C.

Note:  This can only be done on analyzers which support this option, version 1.3 and higher.

1)	 Choose “Variable Temperature” from the Advanced menu.  A dialog will open asking you to confirm 
that you want variable temperature.  Tests run at temperatures other than 37° C may cause changes to 
results and you must acknowledge that they are changing the temperature from the normal settings.

2)	 Click Accept to agree to the variable temperature terms and conditions.  Once confirmed, the 
Variable Temperature dialog will open.

Temperatures settings are managed with profiles to allow convenient switching between temperature 
configurations.  The “Default” setting will set all analyzer channels to 37° and this setting cannot be changed.

3)	 To add a new profile click the add button (“+”) and give the profile a name.

4)	 To change the temperature of an analyzer’s channel select the row and column in the table and 
choose the desired value.

5)	 Click the “Set” button to set the temperatures for all connected analyzers.

Shutting down Signature Viewer or powering off the analyzers will cause all channels to return back to 37° 
and variable temperatures will need to be reset each time Signature Viewer is started.
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Common Errors and Known Issues

Communication Issues between Signature Viewer and the Sonoclot Analyzer
When an analyzer is connected to Signature Viewer it expects the host computer to communicate with it 
periodically.   If this communication does not occur, Signature Viewer enters the Host Inactive state.  This 
communication protocol must occur every 30 seconds or so.  Under normal operation, Signature Viewer 
communicates with the analyzer every 2 seconds.  Communication problems can occur for the following 
reasons:

Description:	 The host computer has insufficient RAM and stores some program memory on an external 
memory device, the hard disk.  This memory swapping is very slow.

Workaround:	 Install Signature Viewer on a computer with at least 512 MB of RAM.

Description:	 The host computer has a fragmented hard disk and access to data on the hard disk is 
inefficient.

Workaround:	 Install Signature Viewer on a computer with a minimal number of users.

Description:	 Some features of computer operating systems can block other processes.  For example, 
sometimes opening a menu screen on a program can stop the operating system from reading 
the USB port.

Workaround:	 Sienco recommends not entering data, opening additional Signature groups, or using other 
features of Signature Viewer when running a test.

Description:	 Other programs are running in the background that degrade program execution performance 
of Signature Viewer.

Workaround:	 Sienco recommends minimizing the number of programs running at the same time as 
Signature Viewer.

Description:	 Extra features installed on the computer cause program execution to be impaired.
Workaround:	 Avoid installing and running extra features on the same computer as Signature Viewer.

Description:	 The computer has a slow processor.  This can be a common problem with netbooks.
Workaround:	 Install Signature Viewer on computers that meet or exceed the minimum processing speed 

defined on page 1-1.

Description:	 Signature Viewer is deselected as the foreground application by you and the foreground 
program uses sufficient computer resources to delay Signature Viewer.

Workaround:	 Set Signature Viewer as the default foreground application and avoid running other 
applications at the same time as Signature Viewer.

Description:	 The Signature Viewer database grows over time.  As this database grows, program execution 
slows.

Workaround: 	 We recommend that users backup and create new empty versions of Signature Viewer after 
running a few hundred tests or so.  The actual number of tests that can be used without 
degrading performance is dependent on many factors that influence computer performance 
including many of the issues already discussed.  Follow the instructions for archiving and 
resetting the database on page A-4 and A-5.
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Description:	 The power management setting on the computer results in the computer going to sleep.  
Workaround:	 Make sure the sleep settings on your computer are set to wait at least one hour.  Also, 

quitting Signature Viewer when not in use is recommended.

Changing the system time on the host computer causes Signature Viewer to fail
Description: 	 Signature Viewer gets the current time from the operating system when either Signature 

Viewer starts or a new test is started and when either a new data collection group is 
created. If there is a problem with the system time Signature Viewer may fail when 
starting a test or creating a new data collection group.

Workaround: 	 First verify that the time and data is correct. If the time and data are correct and Signature 
Viewer is still failing contact Sienco’s Technical Support at 303-420-1148 or support@
sienco.com.

Failure to shut down Signature Viewer causes Signature Viewer to fail:
Description:	 Running Signature Viewer for extended periods of time may result in program instability.
Workaround:	 Sienco recommends that you quit Signature Viewer after each day of use to ensure 

optimum Signature Viewer performance.

Recalculate Result unable to be selected:
Description: 	 The Recalculate Results under the Signature menu cannot be selected because it is not 

implemented in this release.

Signature Colors and Styles:
Description: 	 Signature colors and styles interferes with Signature data collection.
Workaround: 	 Signature colors and styles can only be changed when no analyzers are connected to 

Signature Viewer. To change Signature colors or styles, start Signature Viewer with the 
analyzer(s) either disconnected from host or unpowered.

Export/Import Group File Names:
Description: 	 Export Signature Group and Import Signature Group do not currently support file names 

that contain non-alphanumeric characters.
Workaround: 	 When exporting Signature groups, make sure that the name of the group contains only 

alphanumeric characters. When importing a Signature Group, ensure that the group’s 
file name contains only alphanumeric characters.
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Warning and Error Messages
The Sonoclot Analyzer and Signature Viewer occasionally display messages that may not be familiar.  Below 
are some examples of these messages and procedures to follow, if necessary.

Warning messages from the Sonoclot Analyzer LDC Display:

Error Code/Message Description Solution

“HOST INACTIVE!” Indicates that the analyzer is either 
not connected to the computer or the 
Signature Viewer application is not 
running.

Check that the analyzer is connected to 
the computer with a USB cord and that 
Signature Viewer is running.

15438

15495

Communication Failure between 
Signature Viewer and the analyzer.

See possible causes and solutions in 
the Common Errors and Known Issues 
section of this chapter.

Warning Messages from Signature Viewer:

Java Virtual Machine could not be found
Follow the installation procedure on the insert of the Signature Viewer Installation CD, making sure the 
steps are performed in the specified order.

Database warning
If the database has become corrupted or Signature Viewer was not shut down properly, a warning box 
will appear when Signature Viewer is opened.

1)	 Continue opening Signature Viewer.  If Signature Viewer opens properly, quit Signature Viewer and 
reopen.  If no further warning messages appear, no further action is required

2)	 If the database warning message appears, archive and reset the database following the instructions 
on pages A-4 and A-5.

If you have any questions in regards to a display message, contact Sienco, Inc. or your distributor.
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Archiving the Database
Signature Viewer version 4.1 saves a copy of all tests in a folder named “cache.” Over time, this folder can 
become filled with a large number of files.  Eventually, the number of files can become so large that the 
performance of Signature Viewer is substantially compromised.  Database initialization should be performed 
periodically to ensure that the size of the cache folder does not get so large that Signature Viewer performance 
is compromised.  Depending on the speed of the computer, the performance of Signature Viewer may begin 
to degrade when approximately 500 to 1000 files have been put into the cache.

All Signature Viewer data and configuration files are located in a user folder. If the default configuration is 
installed, this folder is named “My Signature Viewer Data” and is located in the “My Documents” folder.  This 
procedure makes a backup of the “My Signature Viewer Data” folder and then initializes the “My Signature 
Viewer Data” folder into an empty database.

1)	 Locate the “My Signature Viewer Data” folder by opening the “My Documents” folder.  If the default 
installation was not performed, the “My Signature Viewer Data” folder may be located in another 
directory.

2)	 Make a duplicate of the “My Signature Viewer Data” folder.  The commands to duplicate a folder 
vary depending on the operating system.  In Windows, first click on the folder to select it then right 
click and select Copy.  Next click within the Documents Folder to deselect “My Signature Viewer 
Data” folder then right click and select Paste.  This will make a new folder named “My Signature 
Viewer Data copy.”  Rename the new folder “My Signature Viewer Data - YEAR-MONTH- DAY.”  
For example, “My Signature Viewer Data - 2012-11-14.”  This new folder is the backup folder.

3)	 Open the backup folder, “My Signature Viewer Data - YEAR-MONTH-DAY”.  This folder will contain 
a number of files and folders.  Verify that this folder has at least the following files and folders:

•	USBManager.dll
•	Shortcut to Signature Viewer
•	jydodb.properties
•	jydodb.key
•	svdatabase.s0
•	svdatabase.s1
•	cache

4)	 Open the “My Signature Viewer Data” folder.  This folder will contain a number of files and folders.  
Delete all files and folders except for the following files:

•	USBManager.dll
•	Shortcut to Signature Viewer
•	jydodb.properties
•	jydodb.key
•	SV 4.1 Manual r2 (optional reference document)

5)	 Start Signature Viewer normally.  Typically, this will be done by clicking the Shortcut to Signature 
Viewer icon on the desktop.  When Signature Viewer starts, it will create a new empty database.

6)	 Re-define your enabled tests, applications and ranges, patients and operators following the 
instructions in Chapter 2 of this manual.

7)	 Back versions of Signature Viewer can be run by modifying the “Shortcut to Signature Viewer” 
shortcut located in each backup folder.  Contact support@sienco.com for instructions on modifying 
this shortcut to run the backup database.
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Recovering Signatures and Signature Groups
Signature and signature group files are automatically saved into the “cache” folder in the “My Signature 
Viewer Data” folder that includes the active Signature Viewer database folders.  The files in the cache folder 
are duplicates of the data within the database.

Following are instructions on how to locate, copy, and place archived data files into the current Signature 
Viewer folder and then how to read these files into the active Signature Viewer database.

1)	 Locate the signature and signature group cached files of interest.

Each cached file is exported with its name used as the file name. For typical signatures and signature 
groups, the name is a timestamp.  The automatic filename for each signature follows the pattern, 
yyyy.mm.dd_hh.mm.ss_serialnumber-channel. For example, “2012.01.11_13.01.33_409769-2”.

Each signature group has an automatic filename with the pattern, SG.yyyy.mm.dd_hh.mm.ss.  For 
example, “SG. 2010.03.17_11.27.52”.  The timestamp for a signature group is when the group is 
created.

With these timestamps, you can locate data files for a range of dates.  For example, you can use 
the “Find Files” command in Windows to find files that begin with “2012.02”.  This would locate 
every signature data file on the computer that was collected in February of 2012.  Locating files 
that begin with “SG.2012.02” would find all signature group files that were collected in February 
2012.  Use the search command for your operating system and locate the data files across a range 
of dates of interest.

2)	 Copy the desired files and paste into the “cache” folder within the “My Signature Viewer Data” folder.

3)	 Start Signature Viewer normally.  Typically, this will be done by clicking the Shortcut to Signature 
Viewer icon on the desktop.

4)	 After Signature Viewer starts, execute the menu command “Rebuild from cache” located in the 
“Database...” menu option from the “File” menu.  This process imports the files from the cache 
folder into the active database.

5)	 After the database has been rebuilt, you can use the “Open Signature Group” menu option from the 
“File” menu to open signature groups.  If you have signatures that are not included in any signature 
group you can add them to an empty signature group or any other signature group by using the 
“Add Signatures...” menu option from the “File” menu.  See page 3-7.



Appendix A-6    

Troubleshooting
If you have a problem with Signature Viewer, follow these steps:

1)	 Shut down Signature Viewer.  If Signature Viewer is unresponsive, force it to quit using the Activity 
Monitor (Windows Ctrl-Alt-Delete).

2)	 Make sure that Signature Viewer is not in use by another user on the computer.

3)	 Disconnect the USB cord.

4)	 Restart the analyzer by unplugging the power cord and plugging it back in.

5)	 Reconnect the USB cord.

6)	 Restart Signature Viewer.

7)	 If problems persist, contact the Sienco service department: 

Phone: 303-420-1148
Toll Free: 800-432-1624

Fax: 303-379-4403
E-mail: sienco@sienco.com

Mail: Sienco Service Department
5721 Arapahoe Ave, Unit A1-A
Boulder, CO 80303 USA

Glossary of International Symbols

Manufacturer Do not reuse

In Vitro Diagnostic medical 
device

Model Number

Authorized representative in 
the European community

Lot Number

CE marking of conformity Manufacture date

Biological risk Expiration date

Temperature limitation Consult instructions for use

Humidity limitation Contains sufficient for <n> tests

Direct current (DC)
Caution, consult accompanying 
documents

Serial number     Control

Do not dispose of electrical 
equipment as municipal waste


